Анимация Фигур

From Synfig Studio :: Documentation
< Doc:Flower Animation
Revision as of 12:16, 1 February 2012 by Zurba11 (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
Languages Language: 

English • español • français • italiano • português • română • русский • 中文(中国大陆)‎

Warning!

This page contains outdated information.

The release of Synfig Studio 0.64.0 introduced new terminology and this translated page needs to be updated according to original English text.

You can help updating this page - see instructions here. Thank you!

warning end


Подготовительный этап

В этой статье вы узнаете как создать простую анимацию растущего цветка используя BLines.

Flower 0.png

Запустите Synfig Studio — откроется новый файл. Если Synfig Studio уже был запущен, то выберите "File → New" ("Файл → New") на панели инструментов.

Первое что нужно создать это градиентная заливка для фона. Выберите цвет заливки и контура на панели инструментов которые будет иметь наш градиент. Вы также можете напрямую редактировать градиент с помощью линии градиента.

Выберите инструмент "Градиентная заливка" на Панели Инструментов и проведите вертикальную линию курсором вдоль холста чтобы получить результат.

Далее выбирете BLine Tool (Кривые) и убедитесь что только "Create Region BLine" (Создать кривую области) отмечена на Панели Параметров Инструментов. На Панели Инструментов установите цвет заливки на зелёный. Нарисуйте фигуру вроде треугольника с помощью BLine Tool (Кривые). Чтобы замкнуть фигуру после того как вы нарисуете три вершины, кликните правой кнопкой мыши на первой и выберите "Loop BLine" (Замкнуть Контур).

Теперь контур замкнут, вы можете закончить его создание нажав на другой инструмент или на кнопку с шестерёнками расположенную внизу Панели Параметров Инструмента.

FlowerTutorialCanvas1.png

Это будет основа стебля. Вы можете немного подрегулировать вершины касательных линий (красные точки) чтобы получить закруглённые углы. Выбрав Transform Tool (Инструмент Трансформирования) кликните правой кнокой на каждой вершине и выберите "Split Tangents" (Разделить Касательные), теперь точки касательных каждой вершины могут регулироваться отдельно друг от друга. На этом подготовительный этап закончен.

FlowerTutorialCanvas2.png

Анимация стебля

Войдит в меню холста нажав на иконку caret menu(Кнопка вызова меню) в верхнем левом углу там где пересекаются линейки и выберите "Edit → Properties"(Правка>Properties). Перейдите на вкладку Time tab (Время) и установите "End time"(Время конца) на "6s" после чего смело жмите ок.

Установите значение времени на начало ("0f") после чего на панели Ключевых Кадров Keyframes Panel (Той что с ключиком на иконке) нажмите на кнопку с "+" (Добавить новый ключевой кадр). Keyframes (Ключевые кадры) позволяют нам контролировать сцену, то есть на ключевом кадре "запоминаються" все свойства каждого элемента сцены. Теперь установите значение времени на "4.5s". Нажмите на зелёный кружок в нижнем правом углу холста (или на ту иконку которая находиться на его месте, если у вас отличаеться тема оформления) чтобы переключиться в Animate Editing Mode (Режим редактирования анимации), обратите внимание что теперь кружок стал красным.

С помощью Transform Tool (Инструмент Трансформирования) выберите зелёный росток и потяните верхнюю точку чтоб получить стебель. Вы можете используя касательные вершин слегка изогнуть форму если захотите.

FlowerTutorialCanvas3.png

Оставаясь на отметке времени "4.5s" кликнете правой кнопкой мыши на край стебля, ближе к вершине, и выберите "Insert Item (smart)" (Вставить Узел (Умно)). Сделайте то же самое с другой стороны стебля. Кликните правой кнопкой мыши на каждой из этих новых точек и выберите "Split Tangents" (Разделить касательные). Теперь попробуйте сделать форму как на рисунке, чтобы получился бутон.

FlowerTutorialCanvas4.png

Теперь если вы кликните например на "2s" вы заметите что форма бутона немного проступает даже если росток ещё совсем маленький.

FlowerTutorialCanvas5.png

Нам скорее надо чтобы бутон появился на 3.5s и полностью сформировался к 4.5s.

И так устанавливаем значение времени на "3.5s". Теперь взгляните на панели "Params" (Парметры) и "Timetrack" (Дорожка времени) внизу. Вы заметите что что каждому параметру на панели "Params" (Парметры) соответствует дорожка на "Timetrack" (Дорожка времени). Самый нижний параметр это список вершин, нажмите на маленькую стрелочку слева чтобы развернуть список. Вы должны увидеть что то похожее на это:

FlowerTutorialTimetrackParamsPanels6.png

Каждая большая зелёная точка или waypoint(Фиксатор) относится к записанному значению (здесь положения вершин были изменены на 0f в ключевом кадре и на 4s когда мы изменяли вершины и их касательные). Две вершины которые мы добавили чтобы получить бутон отмечены как "DYN" (динамичные), кликните правой кнопкой на них в списке параметров и выберите "Mark Activepoint as Off" (пометить активную точку как выключенную).

Панель теперь выглядит вот так, серая часть показывает время в течении которого вершины бутона не влияют на стебель.

FlowerTutorial-7-WaypointsActivepointsOff.png

Например, если вы теперь вернётесь на отметку "2s" или даже "3s" то увидите что бутон не заметен. Он начнёт появляться только после 3.5s.

Тем не менее форма стебля может выглядеть не очень натурально пока растёт между 0 и 4 s. Убедитесь что вы в "Режиме редактирования анимации" и подрегулируйте форму в разные моменты времени так чтобы она вас радовала.

Анимация стебля на этом закончена, хотя на нём ещё не хватает лепестков. Вы можете воспользоваться предварительным просмотром анимации: "File → Preview" (Файл>Предпросмотр) какое то время уйдёт на подсчёт кадров и можно смотреть.

Note

Предпросмотр часто выводиться пиксельным и размытым, но финальный рендеринг будет иметь положенную резкость. Более высокого качество предпросмотра можно достичь увеличив значения 'Zoom' (Масштаб) и 'Frames per second'(Кадров в секунду) в диалоговом окне предпросмотра.
note end


Добавляем лепестки

Теперь нажмите красный кружок в правом нижнем углу холста чтобы покинуть "Animate Editing Mode" (Режим редактирования анимации)

Поменяйте цвет заливки на розовый и нарисуйте лепесток с помощью BLine Tool (Кривые). Как видите зелёная контрольная точка duck с помощью которой можно перемещать фигуру, находиться в центре холста. Выделите все вершины лепестка нажав CtrlA и подвиньте его ближе к зелёной контрольной точке (с помощью Инструмента Трансформации) как на рисунке.

FlowerTutorial-8.png

Теперь подтяните зелёную контрольную точку близко к вершине бутона, опять нажмите CtrlA чтобы выделить все вершины лепестка и поверните его немного с помощью Rotate Tool (Вращение). Ещё надо будет на Layers Panel (Панель "слои") выделить слой лепестка и установить его ниже стебля. Кликнете на лепесток и стебель удерживая ctrl. Оба объекта теперь должны быть выделены.

Удерживая ctrl выберите верхнюю точку на стебле и зелёную контрольную точку лепестка (Точки должны окраситься ярче указывая что они выделены), после чего нажмите правой кнопкой на верхнюю точку стебля и выберите "Link"(Связь). Лепесток слегка сдвинется в сторону.

FlowerTutorial-9.png

Теперь есть невидимая связь между лепестком и вершиной стебля, когда вершина стебля движется, лепесток движется за ней (вообщем то если движется контрольная точка лепестка то тогда за ним будет двигаться вершина стебля, но сейчас нам этого не надо).

На панели "Слои" выберите слой с лепестком и скопируйте его (с помощью кнопки копирования в буфер, внизу панели). Теперь снова нажмите CtrlA чтобы выделить все вершины скопированного лепестка и сдвиньте его, теперь оба лепестка видны и не закрывают друг друга (не перемещайте зелёную контрольную точку, двигайте только оранжевые). Повторите это действие несколько раз пока не получиться что то похожее на рисунок внизу.

FlowerTutorial-10.png

Имейте в виду что скопированные лепестки также связанны со стеблем как и оригинал. Если вы теперь вернётесь к первому ключевому кадру то заметите что лепестки видны и на нём, это нас не устраивает. Нам нужно чтобы лепестки появились и расцвели почти в самом конце роста.

Прячем лепестки

И так, предположим нам надо чтобы лепестки немного появились после 4 секунды и полностью раскрылись к 5 секунде вместо того чтобы быть видимыми и большими всё время.

Переключитесь на "Animate Editing Mode" (Режим редактирования анимации) нажав на зелёный кружок в нижнем правом углу холста. Правда если мы просто перейдём на "4s" и исправим лепестки то они изменяться и на "5s" потому что форма и положение лепестков не зафиксирована никакими ключевыми кадрами или фиксаторами (зелёными точками на линии времени). Это значит что нам надо поставить ключевой кадр на "5s", для этого установите дорожку времени на 5 секунд после чего на Keyframes Panel (Панели Ключевых Кадров) нажмите "+" чтобы добавить новый ключевой кадр.

Теперь вернитесь на "4s" и на Панели Слоёв выделите все слои с лепестками (С помощью ctrl+клик), потом нажмите CtrlA чтобы выделить все вершины лепестков. Осталось их только уменьшить с помощью Scale Tool (Масштабирование) и спрятать их под стеблем как на рисунке.

FlowerTutorial-11.png

Между 4s и 5s лепестки теперь появляются и расцветают, но у нас есть ещё один ключевой кадр на 0s который также "помнит" форму лепестков, так что у нас проблема — лепестки всё ещё видимы с первого кадра до 4s. Мы можем либо сделать лепестки микроскопическими и прятать их в таком виде на всём протяжении от 0s до 4s, либо мы можем сделать их невидимыми на это время.

Выберем второй путь. Чтобы сделать всё проще мы применим encapsulate ("инкапсуляция" или изолирование) лепестков в Inline Canvas (Объединяющий слой). Выделив все слои с лепестками кликните на них правой кнопкой на панели слоёв и выберите "Encapsulate" (Изолировать). Вы можете переименовать Объединяющий слой назвав его "Лепестки" чтоб было понятно что в нём находится.

FlowerTutorial-12.png

Выделите объединяющий слой "Лепестки" и переместитесь на первый ключевой кадр. На панели параметров установите значение "Amount" (Величина) на 0. Теперь лепестки невидимы на этом кадре, заметьте что появилось два фиксатора напротив "Amount" (Величина), один на 0s и другой на 5s. Перетащите фиксатор с 5s на 4s чтобы начиная с 4s лепестки снова были непрозрачными, а значение "Amount" (Величина) равно 1.

FlowerTutorial-13.png

Но одна проблема всё ещё остаётся, с 0s по 4s непрозрачность лепестков медленно увеличивается, делая лепестки видимыми когда не надо, чтобы решить её мы изменим значение интерполяции. Нажмите правой кнопкой на фиксатор находящийся напротив "Amount" (Величина) на 0f и выберите "Edit" (правка), появиться диалоговое окно в котором вы можете выбрать значение для: "in"(Интерполяция на входе) и "out"(Интерполяция на выходе). Установите значение "out" (Интерполяция на выходе) на "Constant" (Константа).


FlowerTutorial-14.png

Tip

Вы также можете изменить "out" нажав правой кнопкой на фиксатор и выбрав "Out → Constant" (Выход>Постоянная).
note end


Изменение значения "out" на "Constant" означает что на протяжении времени от этого фиксатора до следующего значение "Amount" (Величина) будет оставаться постоянным, то есть на протяжении от 0f to 4s значение будет равно 0, а на 4s сразу изменится и станет равно 1, что сделает лепестки видимыми как мы и хотим. Можно достичь тот же эффект изменив значение "in" (Интерполяция на входе) на "Constant" (Константа) применительно к фиксатору находящемуся на 4s.

Заметьте что половина зелёной точки "фиксатора" изменила свою форму и если раньше она означала плавную анимацию значения "Amount" (Величина), то теперь превратившись из зелёного полукруга в красную "ступень" стала означать что оно будет изменяться резко.

Теперь мы закончили. Стебель растёт до 4.5 секунд и затем не меняет своего положения оставшиеся 1.5 секунды. Лепестки не видны до 4 секунды, а затем быстро "расцветает" между 4 и 5 секундами, после чего также не двигаются оставшуюся секунду.

Нажмите на "File → Render" (Файл>Визуализация) чтобы "отрендерить" анимацию. Выберите любой формат файла какой захотите и убедитесь что снята галочка с "Use current frame" (Использовать текущий кадр), иначе будет визуализован только один кадр.


Languages Language: 

English • español • français • italiano • português • română • русский • 中文(中国大陆)‎