Difference between revisions of "Doc:Following a Spline"

From Synfig Studio :: Documentation
Jump to: navigation, search
m (started with a copy of "Following a BLine (the old way)")
m (update link)
 
(35 intermediate revisions by 12 users not shown)
Line 1: Line 1:
<!--Categories-->
+
<!-- Page info -->
[[Category:Tutorials]]
+
{{Title|Following a Spline}}
 
+
{{Category|Tutorials}}
 +
{{Category|Tutorials Advanced}}
 +
{{NewTerminology}}
 +
<!-- Page info end -->
 +
:Note: There is also a slightly out-of-date tutorial on this topic at [[Tracking Curves]].  It contains some info, particularly about link/export, '''which hasn't yet been added to this new tutorial'''.  There is also another [[Following a BLine (the very old way)|very out-of-date tutorial]] for synfig 0.61.08.
 
== Introduction ==
 
== Introduction ==
  
This is only a rough draft.  The content should be OK, but it needs tidying up and could really benefit from some screen shots.  If you follow the tutorial, please consider taking some shots as you do so and uploading them here...
+
This tutorial will demonstrate how to make an object follow the path of an arbitrary curve, rotating to face the direction of travel.
 
+
[http://sourceforge.net/tracker/index.php?func=detail&aid=1781903&group_id=144022&atid=757419 This bug report] suggested a feature:
+
 
+
<blockquote>
+
I would like to be able to draw a bline with N vertices and have
+
a shape move along that bline (the whole shape or individual vertices).
+
Currently the only way I have found to do what I want is to draw a bline,
+
and then move a shape along that line manually at fairly small intervals
+
(very frustrating).
+
 
+
Example: A triangle that should move along a sine curve always pointing in
+
the direction it is going to move next.
+
</blockquote>
+
 
+
The feature has recently been added to Synfig (23rd September 2007) and will be in the next release.
+
  
 
== Summary ==
 
== Summary ==
Line 25: Line 14:
 
We're going to:
 
We're going to:
  
* [[Following a BLine#Create the Layers|Draw a curve and an arrow]]
+
* {{l|Doc:Following a Spline#Create the Layers|Draw a curve and an arrow}}
* [[Following a BLine#Make the Arrow Move|Link the arrow's Origin]] to the curve's Vertices' vector position so the arrow follows the curve
+
* {{l|Doc:Following a Spline#Make the Arrow Move and Rotate|Link the arrow's Origin and Rotation}} to the Spline so the arrow follows the curve
* [[Following a BLine#Make the Arrow Rotate|Link the arrow's Rotate layer]] to the curve's Vertices' tangent so the arrow rotates with the curve
+
  
 
== Tutorial ==
 
== Tutorial ==
Line 36: Line 24:
  
 
File > New
 
File > New
 
Time tab > End Time > 10s > OK
 
  
 
=== Create the Layers ===
 
=== Create the Layers ===
  
select the BLine Tool
+
Select the {{l|Spline Tool}}
 +
[[File:Spline-tool-0.63.06.png|frame|none]]
  
 
enable just the Outline checkbox
 
enable just the Outline checkbox
  
draw a bline that you want the arrow to move along
+
draw a spline that you want the arrow to move along
  
select the new bline layer, go to its parameters
+
click the {{Literal|Make Spline}} icon in the bottom left of the {{l|Tool_Options_Panel}} to create the spline.
  
right-click on the vertices parameter and "export" it
+
still in the Spline Tool, enable {{Literal|Create Outline}} and {{Literal|Create Region}} checkboxes in tool options
it will ask for a name.
+
[[File:Spline-Tool-Options_0.63.06.png|frame|center]]
  
you can use whatever name you like but for this tutorial I'm calling it "path"
+
draw an arrow or whatever, pointing to the right.
  
(note that you could have checked the 'auto export' box in the draw tool, and set the name in the text box at the top of the tool options to save having to chose export from the menu - it doesn't matter which you use)
+
Switch to the {{l|Transform Tool}}
  
switch back to the 'Normal' tool and look in the "Children" dialog.
+
select the outline, hit control-a to select all its {{l|Handle|handles}} except the green position handle
  
expand the ValueBase Nodes and you'll see all the things that have been exported.
+
drag the handle so that the arrow is centred around the green position handle
  
selecting them will allow us to re-use them elsewhere in the animation later
+
Add a {{l|Rotate Layer}} above the outline and region
  
back in the bline tool, enable Fill and Outline checkboxes in tool options
+
{{l|Group}} the rotate, outline, and region layers
  
draw an arrow or whatever, pointing to the right
+
so now you've got 2 top-level layers: a curved path, and a group containing an arrow and a rotate layer
  
select the outline, hit control-a to select all its ducks except the green position duck
+
=== Make the Arrow Move and Rotate ===
  
drag the ducks so that the arrow is centred around the green position duck
+
* Select the group layer by clicking it in the {{l|Layers Panel}}
 +
* Select its green position {{l|Handle|handle}} by clicking on it in the {{l|WorkArea}}
 +
** additionally select the Rotate layer by holding Control and clicking it in the Layers panel
 +
** additionally select the blue "rotation amount" handle by holding {{Shortcut|ctrl}} and clicking on it in the canvas window
  
add a rotate layer above the outline and region
+
So now we should have 2 layers selected, and one handle from each of those 2 layers selected
  
encapsulate the rotate, outline, and region layers
+
Now additionally select the curved spline layer (it should be the last layer in the Layer panel's list) by holding {{Shortcut|ctrl}} and clicking on it
  
rename the encapsulation layer "arrow"
+
Right-click on the dotted line that indicates the position of the curved spline - not on any handle, but on the dotted line between handle
  
so now you've got 2 top-level layers: a curved path, and an encapsulation containing an arrow and a rotate layer
+
From the context menu that pops up, select {{Literal|Link to Spline}}
 +
[[Image:Spline-Link-to-0.63.06.png|none|frame|See also {{l|Command:Link_to_Spline}} ]]
  
=== Make the Arrow Move ===
+
The arrow group should move so that its green position handle is on the spline, and it should rotate so that the arrow points along the spline at that point
  
select the "arrow" encapsulation layer
+
Select just the group layer, and drag its green handle around.  you'll see that the handle is constrained now to line on the spline, and that dragging it also affects the rotation of the arrow as expected
  
we want this layer to move along the "path" bline.  the Origin parameter of an encapsulation layer can be used to move everything it contains
+
We can now animate the arrow. turn on {{l|Animate_Editing_Mode}} by clicking the icon in the bottom right of the canvas window.
right-click the Origin parameter and select [[Convert#BLine_Vector|Convert > BLine Vertex]]
+
the Origin parameter will now be expandable - click the small triangle to its left to expand it
+
  
the Origin of the "arrow" layer is now defined by 3 sub parameters: a BLine, the amount to travel along the BLine, and a checkbox that we'll ignore for now.
+
* at time '''0f''', drag the group layer's green position handle to one end of the spline
in the Children dialog, select the "path" ValueNode
+
* at time '''5s''', drag the same position handle to the other end of the spline
  
then in the Params dialog, right-click on the "arrow" layer's BLine sub-parameter and "Connect" it to the selected "path" value
+
Try {{c|<Caret Menu>|<File>|Preview|}} to watch the animation.
  
the arrow will move so that it is about half-way along the BLine path (because the Amount sub-parameter defaults to 0.5).
+
== Results ==
  
edit the Amount sub parameter to 0 and to 1, and see the arrow moves to one end of the path and then the other.
+
This is the animation I ended up with:
 +
[[File:Arrow-follows-bline.gif|center|alt Following a Spline example]]
  
the "Loop" sub parameter determines what happens if you use a value outside the range 0-1 for the Amount.  If "Loop" isn't checked, values less than 0 count as 0 and values greater than 1 count as 1.  If "Loop" is checked, the value wraps around, so Amounts of 2.4, 1.4, 0.4, -0.6, -1.6, etc all act the same.
+
Synfig project : {{l|Media:Arrow-follows-bline.sifz‎|Arrow-follows-bline.sifz‎}}
 
+
So we've got the arrow moving along the line, but only if we manually edit the Amount parameter.  Let's get it to move automatically, by converting the constant Amount parameter into a linearly changing value.
+
 
+
Right-click the Amount parameter, and Convert it to Linear.  This adds sub parameters Rate (how fast the value goes up, per second) and Offset (what value it has at time zero).
+
 
+
Set Rate to 0.1 and Offset to 0.  That will make the value of Amount be 0 at time 0 and 1 at time 10s, so the arrow will move from one end of the line to the other throughout the course of the animation.
+
 
+
This linearly changing value of the Amount parameter will be useful later on, so let's export it into the Children dialog so we can find it easily later.  Right-click the Amount parameter and Export it as "engine".  I call it "engine" because this is the parameter that drives the animation.
+
 
+
Try File > Preview or View > Play to watch the animation.  If you like, play with the sub-parameters - turn the Rate up to 0.25 and turn on the Loop checkbox and watch the preview again.  You'll see that the arrow moves 3 times faster than before, reaching the end of the line after 4 seconds.
+
 
+
Turning Loop on means that it will then reappear at the start of the line, and keep moving.  Not having Loop on would make it stay at the end of the line until the animation stopped.
+
 
+
Note that instead of using a Convert>Linear conversion to get the Amount sub-parameter to change over time, we could have used the more traditional method of turning on [[Animate Editing Mode]] and adjusting the parameter at different points in time.  Either way, we can still export the Amount parameter so that we can use it again in the next step.
+
 
+
=== Make the Arrow Rotate ===
+
 
+
You'll notice that although the arrow moves along the line, it doesn't rotate to face the direction of travel.  But that's what we're going to use the Rotate layer for.
+
 
+
Open up the "arrow" encapsulation layer and select the Rotate layer inside. 
+
 
+
Right-click the Amount parameter, which specifies the amount to rotate, and Convert it to type [[Convert#BLine Tangent|BLine Tangent]].
+
 
+
Open up the sub parameters, select the "path" value in the children dialog, and connect it to the rotate layer's BLine sub-parameter, and select the "engine" value in the children dialog and connect it to the rotate layer's Amount sub-parameter.
+
 
+
Now watch the preview and you'll see that the arrow is moving along the line, rotating to face the way it's traveling.
+
 
+
== Results ==
+
  
This is the animation I ended up with: [[Media:Arrow-follows-line-tut.sifz|arrow-follows-line-tut.sifz]]
+
== Controlling the linear velocity ==
  
== Commentary on the Feature ==
+
By default, the arrow travels the whole spline with a constant velocity, independently of the spline structure.
  
I've noticed that if Loop is on, and amount is 1.0, then it acts as if amount is 0.0, ie. the arrow jumps back to the beginning of the line in the last frame.
+
If you select the group layer and look at the Parameters Panel, then you'll see that its Origin parameter is {{L|convert|converted}} to {{Literal|Spline Vertex}} type. This is done automatically when you do "Link to Spline" action. You can disable the  "Homogenous" subparameter and then the speed of the arrow will depend on the spline structure - it will take the same time to move along each segment of the spline. So if there's a long straight part then a bendy complex part, the arrow will move much faster along the straight parts (since there will be less vertices in that part). In physics terms, the linear velocity (that is, the speed over the spline) is not constant.
  
Also, the arrow takes the same time to move along each segment of the bline. So if there's a long straight part then a bendy complex part, the arrow will move much faster along the straight parts (since there will be less vertices in that part).
+
For illustration of the "Homogenous" effect see [http://www.youtube.com/watch?v=3PGXroxBcuo this demo].
  
It would be good to have the option of having the arrow move at constant speed along the length of the curve.
+
== See also ==
 +
* Synfig forum : [http://www.synfig.org/forums/viewtopic.php?f=8&t=4563 Following a path duplicated]
 +
* Synfig forum : [http://www.synfig.org/forums/viewtopic.php?t=2803 animate a "travel path"]
 +
* Synfig forum : [http://www.synfig.org/forums/viewtopic.php?f=8&t=9157 A path of scraps(or any other object)]
 +
* Link to Spline command : {{l|Command:Link_to_Spline}}
 +
* A [https://youtu.be/d1hPxgq2qeU video link] showing the explanation of this page.

Latest revision as of 20:55, 20 July 2019

Languages Language: 

English • čeština • Deutsch • español • français • русский


Note: There is also a slightly out-of-date tutorial on this topic at Tracking Curves. It contains some info, particularly about link/export, which hasn't yet been added to this new tutorial. There is also another very out-of-date tutorial for synfig 0.61.08.

Introduction

This tutorial will demonstrate how to make an object follow the path of an arbitrary curve, rotating to face the direction of travel.

Summary

We're going to:

Tutorial

This is a brief tutorial giving an example of how to use it:

Create the Animation

File > New

Create the Layers

Select the Spline Tool

Spline-tool-0.63.06.png

enable just the Outline checkbox

draw a spline that you want the arrow to move along

click the "Make Spline" icon in the bottom left of the Tool Options Panel to create the spline.

still in the Spline Tool, enable "Create Outline" and "Create Region" checkboxes in tool options

Spline-Tool-Options 0.63.06.png

draw an arrow or whatever, pointing to the right.

Switch to the Transform Tool

select the outline, hit control-a to select all its handles except the green position handle

drag the handle so that the arrow is centred around the green position handle

Add a Rotate Layer above the outline and region

Group the rotate, outline, and region layers

so now you've got 2 top-level layers: a curved path, and a group containing an arrow and a rotate layer

Make the Arrow Move and Rotate

  • Select the group layer by clicking it in the Layers Panel
  • Select its green position handle by clicking on it in the WorkArea
    • additionally select the Rotate layer by holding Control and clicking it in the Layers panel
    • additionally select the blue "rotation amount" handle by holding Ctrl and clicking on it in the canvas window

So now we should have 2 layers selected, and one handle from each of those 2 layers selected

Now additionally select the curved spline layer (it should be the last layer in the Layer panel's list) by holding Ctrl and clicking on it

Right-click on the dotted line that indicates the position of the curved spline - not on any handle, but on the dotted line between handle

From the context menu that pops up, select "Link to Spline"

The arrow group should move so that its green position handle is on the spline, and it should rotate so that the arrow points along the spline at that point

Select just the group layer, and drag its green handle around. you'll see that the handle is constrained now to line on the spline, and that dragging it also affects the rotation of the arrow as expected

We can now animate the arrow. turn on Animate Editing Mode by clicking the icon in the bottom right of the canvas window.

  • at time 0f, drag the group layer's green position handle to one end of the spline
  • at time 5s, drag the same position handle to the other end of the spline

Try "<Caret Menu> → <File> → Preview" to watch the animation.

Results

This is the animation I ended up with:

alt Following a Spline example

Synfig project : Arrow-follows-bline.sifz‎

Controlling the linear velocity

By default, the arrow travels the whole spline with a constant velocity, independently of the spline structure.

If you select the group layer and look at the Parameters Panel, then you'll see that its Origin parameter is converted to "Spline Vertex" type. This is done automatically when you do "Link to Spline" action. You can disable the "Homogenous" subparameter and then the speed of the arrow will depend on the spline structure - it will take the same time to move along each segment of the spline. So if there's a long straight part then a bendy complex part, the arrow will move much faster along the straight parts (since there will be less vertices in that part). In physics terms, the linear velocity (that is, the speed over the spline) is not constant.

For illustration of the "Homogenous" effect see this demo.

See also


Languages Language: 

English • čeština • Deutsch • español • français • русский