Getting Started

From Synfig Studio :: Documentation
Jump to: navigation, search
(A Interface do Usuário)
m ({{TOCright}} + interface)
 
(43 intermediate revisions by 6 users not shown)
Line 1: Line 1:
<!--Categories-->
+
<!-- Page info -->
[[Category:Tutorials]]
+
{{Title|Getting Started|Iniciando}}
 +
{{Navigation|Category:Manual|Doc:Animation_Basics}}
 +
{{TOCright}}
 +
{{Category|Manual}}
 +
{{Category|Tutorials}}
 +
{{Category|Tutorials Basic}}
 +
{{NewTerminology}}
 +
<!-- Page info end -->
  
== Introdução ==
+
== Interface do Usuário ==
 +
A captura de tela abaixo mostra a disposição da janela do Synfig Studio:
 +
[[File:Interface 1.0.png|600px|thumb|center|border|Default interface layout of Synfig Studio]]
  
Synfig, como a maioria dos melhores programas gráficos, quebra individualmente os elementos do [[canvas.es|palco]] em várias [[layer|camadas]]. Porém, difere de outros programas de duas maneiras importantes:
+
Os principais componentes da interface do Synfig Studio são:
  
{| border="0" cellspacing="0" align="center" width="100%"
+
* {{l|Toolbox|Caixa de Ferramentas}} &mdash; é a janela principal do Synfig Studio. Ela contém o menu do sistema e botões, ferramentas e mais para criar e editar seu trabalho. Ao fechá-la você sai do aplicativo.
|
+
* {{l|Canvas|Tela}} &mdash; mostra seu trabalho e animações.
# Uma camada individual no Synfig em geral representa um “Primitiva” única. Por exemplo: Uma região única, o delineado de uma região, um JPEG importado, etc... Isto lhe permitira uma grande flexibilidade e controle. Não é incomum, ter uma composição com centenas de camadas (organizadas na hierarquia definida pelo artista).  
+
* {{l|Category:Panels|Painéis}}&mdash; contém ferramentas e informação sobre certos elementos de seu projeto. Alguns painéis permitem que você modifique esses elementos.
  
# Uma camada só pode ter informação acima da imagem, abaixo dela, não a modificaria de forma alguma. Neste sentido, as camadas no Synfig atuam como filtros, semelhante ao Adobe Photoshop ou GIMP. Por exemplo, se temos uma  [[Blur Layer|camada com desfoque]], uma [[Radial Blur Layer|camada com desfoque radial]], [[Spherize Layer|camada esferizada]], [[Color Correct Layer|camada com correção de cor]], [[Bevel Layer|camada com bisel]], etc...
+
{{Note|Nota|O Synfig Studio pode ser redefinido para seu arranjo padrão de janela (como mostrada na imagem). No menu {{Literal|Arquivo}} da Caixa de Ferramentas, selecione {{c|Panéis|Redefinir a Janela para a Disposição Original}}.}}
  
Cada camada tem sua série de parametros, que determinan seu comportamento. ao clicar em uma camada (seja na janela do palco, ou no [[Layers Panel|painel de camadas]]), verás seus parametros no [[Params Panel|Painel de Parâmetros]].  
+
A janela do centro é chamada de {{L|Category:Canvas_Window|Janela da Tela}}. Toda vez que você iniciar o Synfig Studio, uma nova tela é aberta. A janela representa a {{l|Root Canvas|Tela Raiz}}, não que isso signifique muito para você no momento, mas tudo bem &mdash; estamos apenas tentando te apresentar as redondezas. No canto superior esquerdo desta janela, você verá um botão com uma {{l|Canvas Menu Caret|seta}}. Se você o clicar, o {{l|Canvas Menu Caret|menu da janela da tela}} irá abrir. Se você clicar com o botão direito na área da tela e não houver nenhuma {{l|layer|camada}} embaixo da posição do mouse, este menu também aparecerá. Assim, agora você sabe onde está o menu
 +
mais importante da tela. Ótimo!
  
|| ||  
+
As outras duas janelas (uma na parte debaixo, e a outra à direita) são {{l|dock dialogs|caixas de diálogo embutidas}} customizáveis. Cada diálogo embutido contém um conjunto de {{L|panel|painéis}}, organizados horizontalmente ou verticalmente. Alguns painéis compartilham o mesmo espaço dentro da caixa de diálogo e é possível alternar entre eles clicando nas suas {{l|panel tab|abas}}. Você pode rearrumar o conteúdo dos diálogos como desejar, arrastando as abas para onde quiser que elas fiquem. Você pode, inclusive, criar um novo diálogo, arrastando uma aba para fora de seu diálogo original.
http://i170.photobucket.com/albums/u243/zenoscope/layer.png 
+
|}
+
  
Synfig Studio tem uma propriedade de auto-recuperação. Se travar, mesmo que o arquivo atual não tenha sido gravado, não custará mais que 5 minutos de trabalho. Ao reiniciar, automática e rápidamente alertara ao usuario para que recupere as mudanças guardadas. Infelizmente o histórico ainda não se recupera. Essa propriedade virá mais adiante.
+
Se um {{l|panel|painel}} for acidentalmente fechado (por arrastá-lo para fora de seu diálogo, e fechar o novo diálogo criado), não se preocupe. Simplesmente vá até a {{l|Toolbox|Caixa de Ferramentas}}, selecione {{c|Arquivo|Painéis}} no menu, e clique no nome do painel que você procura.
  
Uma das coisas que te deixará incomodado, é que o Synfig Studio é LENTO, sendo prácticamente obsoleto em máquinas com mais de 3 anos de fabricação. Isto se deve a todo calculo de cor que é feito em ponto flutuante, pois o Synfig Studio foi construido a bartir da base com objetivo de um Processamento Altamente Dinâmico de imagens. ENTRETANTO, isto não durará para sempre.
+
Os painéis mais importantes são:
  
darco tem bastante reimplementações e otimizações planejando agregar e que devem melhor drasticamente o desempenho do Synfig em todas as plataformas. A meta não é chegar a uma melhora de 200% na velocidade, é pelo menos alcançar os 2000%. Com a otimização planejada, seremos capazes de fazer operações de alto desempenho. Deverá também facilitar o caminho para aceleração de hardware usando os melhores procesadores gráficos, que dariam melhoras de grande magnitude.
+
* {{l|Layers Panel|Camadas}} &mdash; mostra a hierarquia da camada de sua tela de trabalho. Ele também permite manipulá-las.
 +
* {{l|Params Panel|Parâmetros}} &mdash; mostra os parâmetros da camada selecionada no momento. Quando várias camadas são selecionadas, apenas os parâmetros que elas têm em comum são exibidos.
 +
* {{l|Tool Options Panel|Preferências de Ferramenta}} &mdash; mostra quaisquer opções específicas da ferramenta selecionada no momento.
 +
* {{l|Navigator|Navegador}} &mdash; mostra uma imagem em miniatura de como a tela atual se parece. Você pode também aproximar e mover o foco com este painel.
 +
* {{l|History Panel|Histórico}} &mdash; mostra o histórico da composição atual. Você pode também editar as ações no histórico.
  
== A Interface do Usuário ==
+
Existem muitos {{l|panel|painéis}} no Synfig Studio. Se você não tem ideia do que um painel faz, simplesmente mantenha o cursor do mouse sobre seu ícone e uma dica irá aparecer, descrevendo sua função.
  
{| border="0" cellspacing="5" align="center" width="100%"
+
== Sob o capô ==
|              |
+
|http://i170.photobucket.com/albums/u243/zenoscope/toolbar.png
+
||            ||
+
  
Ao iniciar o Synfig Studio, se abrirá e levantará splash gráfico. Logo que termine de carregar, deverás ver uma árvore de janelas (estruturada). A janela no canto superior esquerdo é a [[toolbox|caixa de ferramentas]]. Daqui você pode abrir arquivos, mudar de [[tools|ferramentas]], etc. Você notará que a maioria dos botões estão esmaecidos, pois não há nenhum arquivo aberto ainda.
+
[[File:Adding-Layer-tutorial-12 0.63.06.png|right|frame|Layers Panel]]
  
As outras janelas (uma na parte de baixo, e outra à direita) são [[dock dialogs|caixas de diálogo]] configuráveis. Poderá organizar seu conteúdo como quiser apenas arrastando pela aba até onde deseja coloca-la. Também é possível criar um novo diálogo arrastando uma [[dock tab|janela]] fora do diálogo em que estava inserido.
+
O Synfig Studio, como qualquer outro programa gráfico competente, divide elementos individuais de uma {{l|canvas|tela}} em {{l|layer|camadas}}. Entretanto, ele se difere dos outros programas em dois aspectos principais:
  
Se fechar acidentalmente qualquer [[dock tab|janela de dialogo]] (arrastando para fora do dialogo, e fechando a nova janela criada), não se preocupe. Simplesmente na caixa de ferramentas acesse a “Archivo->Dialogos”, e clique sobre o diálogo que precisa.  
+
# Uma camada individual no Synfig geralmente representa um único "Primitivo", ou seja, uma única região, um contorno de uma região, uma imagem importada, etc. Isso permite que se tenha uma grande flexibilidade e controle. Não é incomum a uma composição ter centenas de camadas (organizadas em uma hierarquia, para o bem da sanidade do artista, é claro).
 +
# Uma camada pode não apenas adicionar informação sobre a imagem abaixo dela, mas também distorcer e/ou modificar de alguma outra forma. Neste sentido, as camadas do Synfig agem semelhantemente aos filtros do Adobe Photoshop ou GIMP. Por exemplo, temos uma {{l|Blur Layer|Camada de Desfoque}}, {{l|Radial Blur Layer|Camada de Desfoque Radial}}, {{l|Spherize Layer|Camada Esferizar}}, {{l|Color Correct Layer|Camada de Correção de Cores}}, {{l|Bevel Layer|Camada de Relevo}}, etc...
  
Existem muitos [[dock tab|quadros de diálogo]]. Se não tem a mínima idéia do que´um quadro de diálogo faz, simplesmente aponte o mouse sobre o seu ícone e uma dica de ajuda será mostrada, descrevendo o nome do quadro.
+
Cada camada tem um conjunto de parâmetros que determina como ela irá se comportar. Ao clicar numa camada é selecionada (tanto na janela da tela, quanto no {{l|Layers Panel|Painel de Camadas}} ilustrado à direita), pode-se ver seus parâmetros no {{l|Params Panel|Painel de Parâmetros}}).
|}
+
  
Eis aqui algumas das mais importantes:
+
== Primeiros passos ==
  
* [[Layers Panel|Panel de Camadas]] - Este cuadro muestra la jerarquía de las capas para el lienzo seleccionado. Adicionalmente te permite manipular esas capas.
+
Vamos criar algo divertido para que possamos brincar!
* [[Params Panel|Panel de Parámetros]] - Este cuadro te mostrará los parametros de la capa seleccionada en el momento, (O, si son seleccionadas varias capas, te mostrará únicamente los parámetros que las capas tengan en común) .
+
* [[Categorical Help#Synfig Dialogs|Panel de Herramientas]] - Te muestra cualquier opción especifica de la herramienta seleccionada.
+
* [[Navigator|Navegador]] - Muestra  una miniatura de lo que esté seleccionado en ese momento sobre el lienzo, mostrándote como se verá. Ademas, puedes hacerle acercamiento o alejamiento, y mover el foco por el lienzo.
+
* [[History Panel|Panel del Historial]] - Muestra la lista del historial de la composición actual. Puedes modificar las acciones en el historia.
+
  
Si haces click en en botón “Nueva Composición” que esta en la Caja de Herramientas, una nueva [[Work Area Window|Área de Trabajo]] se abrira.. Haciendo click en el menú circunflejo (entre la regla horizontal y vertical que están en la esquina superior izquierda del área de trabajo), luego en “Ver”, luego en  "Propiedades", y el [[Canvas Properties Dialog|dialogo de propiedades del lienzo]] aparecerá.  
+
Primeiro, vá até a caixa de ferramentas e clique na {{l|Circle Tool|Ferramenta Círculo}} (se você não sabe qual é, apenas passe o mouse sobre elas até achar aquela cuja dica diz "Ferramenta Círculo").
  
El diálogo de propiedades del lienzo es un desastre, lo sé. Tendré que rediseñarlo en algo mucho mas comprensible en algún momento del futuro. Por ahora, ignora la sección "Área de imagen" y "Bloques y enlaces".  
+
Ao clicar nesta ferramenta, você percebe que o {{l|Tool Options Panel|Painel de Opções de Ferramenta}} mudou. Mas falaremos sobre isso mais tarde.
  
Si haces click en OK, el dialogo de propiedades del lienzo desaparecera y verás la [[Canvas window|Ventana del lienzo]]. Esta ventana representa el [[Root Canvas|lienzo Raíz]], eso no significa mucho en este momento, pero eso esta BIEN-- solo estoy tratando de mostrarte los alrededores.
+
Com a Ferramenta de Círculo selecionada você pode, agora, criar círculos na {{l|Canvas Window|Janela da Tela}}. Isto funciona como esperado &mdash; clique na tela, arraste para mudar o comprimento do raio e solte o botão do mouse quando terminar. Vá em frente e crie dois círculos (ou mais, se preferir). Se você acidentalmente soltar o botão do mouse antes de arrastar, vai acabar criando um círculo com raio zero, e ele é realmente invisível! Não se preocupe, você pode consertar isso facilmente. No Painel de Parâmetros, é possível alterar os parâmetros do objeto selecionado. Se você acabou de criar um círculo com raio zero, ele deve ser o objeto atualmente selecionado. Você pode mudar seu raio para algum valor diferente de zero, digamos 10, e manipulá-lo do jeito que você quer usando os puxadores depois.
  
En la esquina superior izquierda de la ventana del lienzo, veras un botón con un simbolo de acénto [[Canvas Menu Caret|circunflejo]]. Si haces click en este botón, la ventana del [[Canvas Menu Caret|menú del lienzo]] se abrirá. (Como acotación, si haces click en cualquier área del [[layer|lienzo]] que no sea parte de la capa, este menú también aparecerá) Ahora, ya sabes donde esta el menu en la ventana del lienzo. Bien. Todo lo demas debería ser bastante auto-explicativo en la ventana del lienzo. (La explicación de las cosas en ese menu viene en un segundo)
+
{{Note|Nota|Alguns usuários podem se deparar com o seguinte problema: quando você clica e arrasta na tela usando a Ferramenta Círculo, parece que nada acontece, ou você acaba fazendo círculos absurdamente grandes. Para consertar isto vá em {{c|Arquivo|Dispositivos de Entrada}} e '''desabilite todos os dispositivos''' que encontrar ali. Se existir algum dispositivo estendido que você deseja usar, como uma caneta sensível a pressão, então o habilite nesta tela. Depois disto, o Synfig irá funcionar como esperado.}}
  
== Primeros Pasos ==
+
Agora, volte à caixa de ferramentas e clique na {{l|Transform Tool|Ferramenta Transformar}} (o botão com a seta nele). Depois disso, clique em um dos seus círculos. Você verá uma {{l|bounding box|Caixa de Contorno}} (que parece inútil no momento, mas não é verdade), um ponto verde no centro, e um ponto azul (ciano) no raio. Esses pontos são chamados ''{{l|handle|puxadores}}''. Se quiser modificar o circulo, clique em um puxador e arraste-o. Fácil!
  
Creemos algo para poder jugar. Ahora que tienes una nueva composición abierta y el dialogo de propiedades esta fuera del camino, ve sobre la caja de herramientas y haz click sobre la [[Circle Tool|herramienta de circulo]]. (Si no sabes cual de todas es, solo mueve el puntero del ratón sobre todas hasta que encuentres la que en la ventana de ayuda dice “círculo”).  
+
É possível selecionar uma {{l|layer|Camada}} clicando sobre ela. Se quiser selecionar mais de uma camada, pressione a tecla {{Shortcut|ctrl}} enquanto clica &mdash; isto funciona tanto na Janela da Tela e no {{l|Layers Panel|Painel de Camadas}}. Experimente!
  
En el segundo en el que hagas click sobre la herramienta circular, deberías darte cuenta de que el  [[Tool Options Panel|Panel de opciones de herramientas]] ha cambiado. Pero iremos luego hacia esa parte.
+
Também é possível selecionar vários puxadores ao mesmo tempo. Você pode fazer isso de muitas formas. Primeiro, pressione {{Shortcut|ctrl}} e individualmente clique nos puxadores que você quer selecionar, mas isso pode ser tedioso. Entretanto, existe um método muito mais rápido &mdash; apenas crie uma caixa de seleção clicando com o mouse e arrastando-o sobre os puxadores que deseja selecionar.
  
: '''Nota''': Algunos usuarios de portátiles podrían experimentar problemas con el click-arrastrar sobre el lienzo usando la [[Circle Tool|herramienta de circulo]], produciendo círculos exagerados o no haciendo nada. El problema es que Synfig ha detectado la almohadilla táctil del ratón y ha activado ese dispositivo (incorrectamente!) Para arreglar esto: Click sobre Archivo->Dispositivos de Entrada... El resultado será una ventana de dialogo, selecciona “deshabilitar” para tu almohadilla táctil del ratón. Luego de cambiar esto, tu ratón externo y la almohadilla táctil del ratón  trabajarán según lo esperado.
+
Vá em frente, selecione dois círculos e todos os seus puxadores. Com vários puxadores selecionados, mover um deles moverá a todos.
 +
<!-- TODO: About rotating and scaling with Ctrl and Alt keys -->  
  
Con la herramienta de circulo seleccionada, ahora puedes crear círculos en el [[Work Area|Área de trabajo]]. Esto trabaja casi exactamente como esperabas que lo hiciese. Anda y crea dos círculos (o más, si así lo quieres). Si por accidente haces click sobre el lienzo en vez de hacer click y arrastrar (con el botón del ratón presionado) para dibujar el circulo, lo que sucedió, fue que creaste un circulo con un radio de 0 y efectivamente es invisible! No hay necesidad de preocuparse, puedes arreglar esto fácilmente. En el panel de parámetros, puedes cambiar los parámetros del objeto seleccionado en ese momento. Si ves una seleccionada con un radio de 0, ese debe ser tu circulo. Puedes cambiar el valor del radio a otro que no sea 0, digamos 10, y manipular desde este panel el objeto que tienes en el lienzo.
+
{{Note|Nota|O Synfig Studio tem uma funcionalidade de autorrecuperação. Se ele pára, mesmo que o arquivo atual não esteja salvo, você não perderá mais que 5 minutos de trabalho. Ao reiniciar, ele automaticamente pedirá para recuperar as mudanças não salvas. Infelizmente, o histórico ainda não é recuperável.}}
  
Ahora vuelve a la caja de herramientas y haz click en la [[Normal Tool|herramienta normal]] (el circulo azul con el puntero encima). Luego de que hagas esto, haz click sobre cualquiera de los círculos. Verás entonces una [[bounding box|caja de atado]](que es medio inservible en este momento, pero yo no estoy de acuerdo), un punto verde en el centro, y un punto cian en el radio. Esos puntos son llamados [[duck|patos]]. Si quieres modificar el circulo, agarra uno de los patos y arrástralo al rededor. Fácil!
+
As ferramentas {{l|Rotate Tool|rotacionar}} e {{l|Scale Tool|escalar}} funcionam de forma muito parecida com a Ferramenta Transformar, exceto quando se tem vários puxadores selecionados. É muito mais fácil tentar do que ler sobre isso. Selecione alguns círculos, selecione todos os puxadores e tente usar as ferramentas de rotacionar e escalar.
  
Ahora puedes seleccionar una [[layer|capa]] haciendo click sobre ella. Si quieres seleccionar mas de una capa, mantén presionado CONTROL mientras les estás haciendo click – esto funciona tanto en el [[Work Area|Área de trabajo]] como en el [[Layers Panel|Panel de capas]]. Pruébalo!
+
Observe que ferramentas que manipulam com puxadores têm opções associadas a elas. Se uma ferramenta em particular não está fazendo o que você quer, dê uma olhada no {{l|Tool Options Panel|Painel de Opções de Ferramenta}} para ver as opções disponíveis.
  
También puedes seleccionar múltiples patos. Puedes hacer esto de varias formas. Primero, puedes mantener presionado CONTROL e individualmente hacer click en los patos que quieras seleccionar, pero esto puede ser tedioso. Sin embargo, hay un método mucho más rápido – solo crea un [[Selection|cuadro de selección]] haciendo click con el ratón y arrastrándolo por sobre el área donde están los patos que quieras seleccionar.
+
== Vinculando ==
  
Anda y selecciona los dos círculos, y selecciona todos sus patos. Con varios patos seleccionados, moviendo uno moverás el resto. Este comportamiento depende de la [[Normal Tool|herramienta normal]]. Así, un nombre más descriptivo para esta herramienta hubiese sido “mover” o “traducir”.  
+
Agora, vamos tentar {{l|linking|vincular}}. Digamos que queremos estes dois círculos sempre do mesmo tamanho. Selecione dois círculos e os respectivos puxadores do raio (os pontos azul ciano).
  
La [[Rotate Tool|herramienta de rotar]] y [[Scale Tool|escalar]] trabajan muy parecido a la [[Normal Tool|herramienta normal]], excepto en el caso donde tienes varios patos seleccionados. Es mucho más fácil probarlo que leer a cerca de ello. Selecciona algunos círculos, selecciona todos sus patos, y trata de usar las herramientas de rotar y escalar.
+
Para selecionar vários manipuladores, é possível tanto arrastar um retângulo sobre a área que os rodeia, quanto selecionar um deles e segurar a tecla {{Shortcut|ctrl}} enquanto se seleciona o resto. Assim que tiver dois puxadores dos raios selecionados, clique com o botão direito do mouse em algum dos dois, e um menu irá abrir. Clique em {{Literal|Vínculo}}. Bum! Os parâmetros estão conectados. É possível provar isto selecionando um dos círculos e mudando o seu raio &mdash; o outro irá mudar também. Muito bom, hein? Eis como os {{l|Outline Layer|contornos}} são fixados às suas {{l|Region Layer|regiões}} &mdash; mas estamos nos adiantando aqui.
  
Nota que, a diferencia de la herramienta normal, las otras herramientas de manipulación de patos TIENEN opciones asociadas con ellas. Si una herramienta particular no esta haciendo lo que quieres que haga, hecha un vistazo en el [[Tool Options Panel|Panel de opciones de la herramienta]] y ve si esta configurada como lo deseas.
+
Vincular é um conceito fundamental no Synfig. Você pode criar vínculos não apenas entre puxadores, mas também entre parâmetros, selecionando várias camadas, clicando com o botão direito do mouse no parâmetro na aba de parâmetros, e selecionando {{Literal|Vínculo}}.
  
== Enlazando ==
+
== Seleção de Cor ==
  
Ahora probemos [[linking|enlazar]]. Supongamos que queremos que estos dos círculos siempre sean del mismo tamaño. Selecciona los dos círculos y luego selecciona los patos correspondientes al radio de ambos (los puntos cian). Para seleccionar múltiples patos, lo haces creando un rectángulo de selección sobre ellos, o seleccionando primero uno, y presionas la tecla CONTROL mientras seleccionas el resto. Una vez que hayas seleccionado el radio de ambos, haz click derecho sobre cualquiera de los dos radios y aparecerá una nueva ventana. Haz click en “enlazar”. Boom. Los parámetros están enlazados juntos. Puedes probarlo tu mismo seleccionado solo uno de los círculos y cambiando su radio – el otro cambiará también. Buena cosa, eh?
+
Digamos que você quer que um dos círculos seja de uma cor diferente. Se você olhar na caixa de ferramentas, abaixo dos botões de ferramentas, está o seletor de contorno/preenchimento, o seletor de largura de contorno, e outras coisas como o método de mistura padrão e o gradiente. A cor de contorno/preenchimento funciona exatamente como se espera &mdash; clique na cor de preenchimento e um modesto diálogo de seleção de cor irá aparecer. Agora você pode alterar as cores facilmente.
  
Enlazar es un concepto fundamental en Synfig. Puedes crear enlaces no solo entre patos, también puedes hacerlo sobre parámetros seleccionando múltiples capas, haciendo click derecho sobre los parámetros en la ventana, y seleccionando “enlazar”.
+
Mas, às vezes, você quer apenas clicar numa cor e pronto. Aqui é onde a aba do editor de paleta entra.
  
<small>DIGRESIÓN: Esto es sobre como los [[Outline Layer|border]] son adjuntados a sus [[Region Layer|regiones]]&mdash;pero me estoy adelantando a mi mismo. En este momento, el poder fundamental y la flexibilidad de enlazar en Synfig Core esta mas allá de lo que Synfig Studio actualmente permite hacer. Esto cambiará en el futuro. De cualquier forma, volvamos a la vía...</small>
+
Clique na aba do painel Editor de Paleta e dê uma olhada &mdash; é aquela com um ícone que se parece com uma paleta. Clicar nas cores com o botão esquerdo do mouse irá automaticamente mudar a cor padrão do contorno, e clicando com o botão do meio do mouse irá mudar a cor de preenchimento.
  
Digamos que quieres que uno de los círculos sea de diferente color. Si ves en la caja que está debajo de las herramientas, verás selector de color, el selector de borde, y algunas otras cosas como el método por defecto de mezcla y las gradientes. La solapa de color de fondo funciona exactamente como crees que va a funcionar – puedes hacer click en el color de fondo, y una modesta paleta de selección de colores aparecerá. Ahora, cambiar el color es bastante fácil.
+
Isso tudo é ótimo, mas nós ainda não mudamos a cor do círculo. Existem três formas para se fazer isto. A primeira é clicar na {{Literal|Ferramenta Preenchimento}} a partir da caixa de ferramentas e então clicar no círculo na Janela da Tela. Bum! O círculo muda de cor. Isso funciona com mais do que círculos. Também, pode selecionar a camada do círculo que deseja modificar, ir ao Painel de Parâmetros, clicar com o botão direito no parâmetro Cor e selecionar {{Literal|Aplicar Cor de Preenchimento}} ou {{Literal|Aplicar Cor de Contorno}}, como preferir. Ou simplesmente dar um duplo-clique no parâmetro da {{Literal|Cor}} - um diálogo do seletor de cor aparecerá e você poderá ajustar à vontade.
  
Pero a veces solo quieres seleccionar un color y seguir de largo. Aquí es donde el editor de paletas sale a relucir. Su el funcionamiento aun no cumple al 100% (ie: guardar y recargar la paleta personalizada aún no ha sido implementado), pero la paleta por defecto es bastante decente. Haz click en la barra del editor de la Paleta y dale un vistazo – es la que que tiene el botón de paleta. Haciendo click en los colores cambiará inmediatamente en la ventana.
+
Tente brincar um pouco com os círculos. Mude os parâmetros e veja o que acontece. Para começar, tente mudar o {{l|Parâmetro Enevoar}} para 5.
  
Todo hasta ahora va bien, pero seguimos sin cambiar el color del círculo. Hay dos formas de hacerlo.  La primera forma es seleccionar el círculo que quieres modificar, ir a los parámetros y hacer doble click sobre el parámetro de color – un dialogo con el selector de colores aparecerá y podrás modificarlo como quieras. Fácil. Solo haz click sobre la “herramienta de relleno” de la caja de herramientas, luego haz click en el círculo de la ventana del lienzo. Boom. El círculo cambio de color. Esto funciona con mas de un círculo, pero llegaremos a eso en un segundo.
+
== Mergulhando mais fundo ==
  
Prueba jugar un poco con los círculos por un rato. Cambia un poco los parámetros, y ve que sucede. Para empezar, juega un poco con el lápiz.
+
É claro, até agora você apenas descobriu como usar as funções básicas do Synfig Studio, mas não sobre como animar um desenho. Isso é abordado na {{l|Doc:Animation_Basics|próxima seção}}.
  
== En profundidad ==
+
{{Navigation|Category:Manual|Doc:Animation_Basics}}
  
Por supuesto, hasta ahora sólo has aprendido a utilizar las características básicas de Synfig Studio pero no como animar un dibujo. Esto podrás verlo en el [[Animation_Basics.es|próximo tutorial]].
+
  You can download an archive who contain the project used for wiki illustration [[File:Interface.zip]]
 +
  You can download the project used for the illustration of the illustration [[File:Spline-DotMan.sifz]]

Latest revision as of 06:41, 30 April 2015

Languages Language: 

English • čeština • Deutsch • español • suomi • français • italiano • 日本語 • Nederlands • polski • português • română • русский • 中文(中国大陆)‎ • 中文(台灣)‎


Navigation Navigation:  <<Manual>>



Interface do Usuário

A captura de tela abaixo mostra a disposição da janela do Synfig Studio:

Default interface layout of Synfig Studio

Os principais componentes da interface do Synfig Studio são:

  • Caixa de Ferramentas — é a janela principal do Synfig Studio. Ela contém o menu do sistema e botões, ferramentas e mais para criar e editar seu trabalho. Ao fechá-la você sai do aplicativo.
  • Tela — mostra seu trabalho e animações.
  • Painéis— contém ferramentas e informação sobre certos elementos de seu projeto. Alguns painéis permitem que você modifique esses elementos.

Nota

O Synfig Studio pode ser redefinido para seu arranjo padrão de janela (como mostrada na imagem). No menu "Arquivo" da Caixa de Ferramentas, selecione "Panéis → Redefinir a Janela para a Disposição Original".
note end


A janela do centro é chamada de Janela da Tela. Toda vez que você iniciar o Synfig Studio, uma nova tela é aberta. A janela representa a Tela Raiz, não que isso signifique muito para você no momento, mas tudo bem — estamos apenas tentando te apresentar as redondezas. No canto superior esquerdo desta janela, você verá um botão com uma seta. Se você o clicar, o menu da janela da tela irá abrir. Se você clicar com o botão direito na área da tela e não houver nenhuma camada embaixo da posição do mouse, este menu também aparecerá. Assim, agora você sabe onde está o menu mais importante da tela. Ótimo!

As outras duas janelas (uma na parte debaixo, e a outra à direita) são caixas de diálogo embutidas customizáveis. Cada diálogo embutido contém um conjunto de painéis, organizados horizontalmente ou verticalmente. Alguns painéis compartilham o mesmo espaço dentro da caixa de diálogo e é possível alternar entre eles clicando nas suas abas. Você pode rearrumar o conteúdo dos diálogos como desejar, arrastando as abas para onde quiser que elas fiquem. Você pode, inclusive, criar um novo diálogo, arrastando uma aba para fora de seu diálogo original.

Se um painel for acidentalmente fechado (por arrastá-lo para fora de seu diálogo, e fechar o novo diálogo criado), não se preocupe. Simplesmente vá até a Caixa de Ferramentas, selecione "Arquivo → Painéis" no menu, e clique no nome do painel que você procura.

Os painéis mais importantes são:

  • Camadas — mostra a hierarquia da camada de sua tela de trabalho. Ele também permite manipulá-las.
  • Parâmetros — mostra os parâmetros da camada selecionada no momento. Quando várias camadas são selecionadas, apenas os parâmetros que elas têm em comum são exibidos.
  • Preferências de Ferramenta — mostra quaisquer opções específicas da ferramenta selecionada no momento.
  • Navegador — mostra uma imagem em miniatura de como a tela atual se parece. Você pode também aproximar e mover o foco com este painel.
  • Histórico — mostra o histórico da composição atual. Você pode também editar as ações no histórico.

Existem muitos painéis no Synfig Studio. Se você não tem ideia do que um painel faz, simplesmente mantenha o cursor do mouse sobre seu ícone e uma dica irá aparecer, descrevendo sua função.

Sob o capô

Layers Panel

O Synfig Studio, como qualquer outro programa gráfico competente, divide elementos individuais de uma tela em camadas. Entretanto, ele se difere dos outros programas em dois aspectos principais:

  1. Uma camada individual no Synfig geralmente representa um único "Primitivo", ou seja, uma única região, um contorno de uma região, uma imagem importada, etc. Isso permite que se tenha uma grande flexibilidade e controle. Não é incomum a uma composição ter centenas de camadas (organizadas em uma hierarquia, para o bem da sanidade do artista, é claro).
  2. Uma camada pode não apenas adicionar informação sobre a imagem abaixo dela, mas também distorcer e/ou modificar de alguma outra forma. Neste sentido, as camadas do Synfig agem semelhantemente aos filtros do Adobe Photoshop ou GIMP. Por exemplo, temos uma Camada de Desfoque, Camada de Desfoque Radial, Camada Esferizar, Camada de Correção de Cores, Camada de Relevo, etc...

Cada camada tem um conjunto de parâmetros que determina como ela irá se comportar. Ao clicar numa camada é selecionada (tanto na janela da tela, quanto no Painel de Camadas ilustrado à direita), pode-se ver seus parâmetros no Painel de Parâmetros).

Primeiros passos

Vamos criar algo divertido para que possamos brincar!

Primeiro, vá até a caixa de ferramentas e clique na Ferramenta Círculo (se você não sabe qual é, apenas passe o mouse sobre elas até achar aquela cuja dica diz "Ferramenta Círculo").

Ao clicar nesta ferramenta, você percebe que o Painel de Opções de Ferramenta mudou. Mas falaremos sobre isso mais tarde.

Com a Ferramenta de Círculo selecionada você pode, agora, criar círculos na Janela da Tela. Isto funciona como esperado — clique na tela, arraste para mudar o comprimento do raio e solte o botão do mouse quando terminar. Vá em frente e crie dois círculos (ou mais, se preferir). Se você acidentalmente soltar o botão do mouse antes de arrastar, vai acabar criando um círculo com raio zero, e ele é realmente invisível! Não se preocupe, você pode consertar isso facilmente. No Painel de Parâmetros, é possível alterar os parâmetros do objeto selecionado. Se você acabou de criar um círculo com raio zero, ele deve ser o objeto atualmente selecionado. Você pode mudar seu raio para algum valor diferente de zero, digamos 10, e manipulá-lo do jeito que você quer usando os puxadores depois.

Nota

Alguns usuários podem se deparar com o seguinte problema: quando você clica e arrasta na tela usando a Ferramenta Círculo, parece que nada acontece, ou você acaba fazendo círculos absurdamente grandes. Para consertar isto vá em "Arquivo → Dispositivos de Entrada" e desabilite todos os dispositivos que encontrar ali. Se existir algum dispositivo estendido que você deseja usar, como uma caneta sensível a pressão, então o habilite nesta tela. Depois disto, o Synfig irá funcionar como esperado.
note end


Agora, volte à caixa de ferramentas e clique na Ferramenta Transformar (o botão com a seta nele). Depois disso, clique em um dos seus círculos. Você verá uma Caixa de Contorno (que parece inútil no momento, mas não é verdade), um ponto verde no centro, e um ponto azul (ciano) no raio. Esses pontos são chamados puxadores. Se quiser modificar o circulo, clique em um puxador e arraste-o. Fácil!

É possível selecionar uma Camada clicando sobre ela. Se quiser selecionar mais de uma camada, pressione a tecla Ctrl enquanto clica — isto funciona tanto na Janela da Tela e no Painel de Camadas. Experimente!

Também é possível selecionar vários puxadores ao mesmo tempo. Você pode fazer isso de muitas formas. Primeiro, pressione Ctrl e individualmente clique nos puxadores que você quer selecionar, mas isso pode ser tedioso. Entretanto, existe um método muito mais rápido — apenas crie uma caixa de seleção clicando com o mouse e arrastando-o sobre os puxadores que deseja selecionar.

Vá em frente, selecione dois círculos e todos os seus puxadores. Com vários puxadores selecionados, mover um deles moverá a todos.

Nota

O Synfig Studio tem uma funcionalidade de autorrecuperação. Se ele pára, mesmo que o arquivo atual não esteja salvo, você não perderá mais que 5 minutos de trabalho. Ao reiniciar, ele automaticamente pedirá para recuperar as mudanças não salvas. Infelizmente, o histórico ainda não é recuperável.
note end


As ferramentas rotacionar e escalar funcionam de forma muito parecida com a Ferramenta Transformar, exceto quando se tem vários puxadores selecionados. É muito mais fácil tentar do que ler sobre isso. Selecione alguns círculos, selecione todos os puxadores e tente usar as ferramentas de rotacionar e escalar.

Observe que ferramentas que manipulam com puxadores têm opções associadas a elas. Se uma ferramenta em particular não está fazendo o que você quer, dê uma olhada no Painel de Opções de Ferramenta para ver as opções disponíveis.

Vinculando

Agora, vamos tentar vincular. Digamos que queremos estes dois círculos sempre do mesmo tamanho. Selecione dois círculos e os respectivos puxadores do raio (os pontos azul ciano).

Para selecionar vários manipuladores, é possível tanto arrastar um retângulo sobre a área que os rodeia, quanto selecionar um deles e segurar a tecla Ctrl enquanto se seleciona o resto. Assim que tiver dois puxadores dos raios selecionados, clique com o botão direito do mouse em algum dos dois, e um menu irá abrir. Clique em "Vínculo". Bum! Os parâmetros estão conectados. É possível provar isto selecionando um dos círculos e mudando o seu raio — o outro irá mudar também. Muito bom, hein? Eis como os contornos são fixados às suas regiões — mas estamos nos adiantando aqui.

Vincular é um conceito fundamental no Synfig. Você pode criar vínculos não apenas entre puxadores, mas também entre parâmetros, selecionando várias camadas, clicando com o botão direito do mouse no parâmetro na aba de parâmetros, e selecionando "Vínculo".

Seleção de Cor

Digamos que você quer que um dos círculos seja de uma cor diferente. Se você olhar na caixa de ferramentas, abaixo dos botões de ferramentas, está o seletor de contorno/preenchimento, o seletor de largura de contorno, e outras coisas como o método de mistura padrão e o gradiente. A cor de contorno/preenchimento funciona exatamente como se espera — clique na cor de preenchimento e um modesto diálogo de seleção de cor irá aparecer. Agora você pode alterar as cores facilmente.

Mas, às vezes, você quer apenas clicar numa cor e pronto. Aqui é onde a aba do editor de paleta entra.

Clique na aba do painel Editor de Paleta e dê uma olhada — é aquela com um ícone que se parece com uma paleta. Clicar nas cores com o botão esquerdo do mouse irá automaticamente mudar a cor padrão do contorno, e clicando com o botão do meio do mouse irá mudar a cor de preenchimento.

Isso tudo é ótimo, mas nós ainda não mudamos a cor do círculo. Existem três formas para se fazer isto. A primeira é clicar na "Ferramenta Preenchimento" a partir da caixa de ferramentas e então clicar no círculo na Janela da Tela. Bum! O círculo muda de cor. Isso funciona com mais do que círculos. Também, pode selecionar a camada do círculo que deseja modificar, ir ao Painel de Parâmetros, clicar com o botão direito no parâmetro Cor e selecionar "Aplicar Cor de Preenchimento" ou "Aplicar Cor de Contorno", como preferir. Ou simplesmente dar um duplo-clique no parâmetro da "Cor" - um diálogo do seletor de cor aparecerá e você poderá ajustar à vontade.

Tente brincar um pouco com os círculos. Mude os parâmetros e veja o que acontece. Para começar, tente mudar o Parâmetro Enevoar para 5.

Mergulhando mais fundo

É claro, até agora você apenas descobriu como usar as funções básicas do Synfig Studio, mas não sobre como animar um desenho. Isso é abordado na próxima seção.

Navigation Navigation:  <<Manual>>


  You can download an archive who contain the project used for wiki illustration File:Interface.zip
  You can download the project used for the illustration of the illustration File:Spline-DotMan.sifz


Languages Language: 

English • čeština • Deutsch • español • suomi • français • italiano • 日本語 • Nederlands • polski • português • română • русский • 中文(中国大陆)‎ • 中文(台灣)‎