Difference between revisions of "FAQ"

From Synfig Studio :: Documentation
Jump to: navigation, search
m (The plant layer doesn't work/displays erratically/doesn't render. Why?)
(test)
Line 1: Line 1:
 +
test
 
== FAQs relating to the current Synfig release (0.61.06) ==
 
== FAQs relating to the current Synfig release (0.61.06) ==
  

Revision as of 05:16, 21 September 2007

Languages Language: 

English • español • français


test

FAQs relating to the current Synfig release (0.61.06)

Many issues are documented in the bug tracker and on the download page.

Can I do anything to improve the stability of the Windows version of Synfig?

If you're running on a Hyperthreading or multi-core CPU (e.g Pentium 4 with Hyperthreading or Intel Core2 Duo or Quadcore, etc.) then you may find Synfig is more stable if you restrict it to run on only one processor. To do this, start Synfig Studio, then Ctrl-Alt-Del and choose Task Manager. Select the processes tab, find synfigstudio.exe in the processes list and right click on it. Choose 'Set Affinity' and make sure only one CPU is checked. Unfortunately, this setting isn't preserved so you either have to do this manually each time you start Synfig Studio or use a tool such as the Tom's Hardware Guide Task Assignment Manager.

Why doesn't dyloxin talk on the Synfig IRC channel]?

dyloxin is a bot that sits in the Synfig IRC channel and stores the IRC logs, not a human. It has no commands, so you won't get any response out of it either.

I have a weird problem building from source. What's up?

Your copy of pkg-config probably doesn't look in the right places for .pc files. If you are installing to /usr/local, try running "export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig" before building or installing anything.

Where did the polygon, draw, sketch, and width tools go?

They are disabled by default due to problems. Instead of the polygon tool, you should use the bline tool. Instead of the width tool, you should just modify the width ducks directly. The draw tool was never completed, is very buggy, and frustrating to use. Since the draw tool is being disabled, then we might as well disable the sketch tool too. You can re-enable them without recompiling by setting some environment variables (you can set environment variables on windows too). Set SYNFIG_ENABLE_POLYGON, SYNFIG_ENABLE_DRAW, SYNFIG_ENABLE_SKETCH and SYNFIG_ENABLE_WIDTH to 1. On Linux/Unix/MacOSX this is as simple as running these commands in a terminal:

export SYNFIG_ENABLE_POLYGON=1
export SYNFIG_ENABLE_DRAW=1
export SYNFIG_ENABLE_SKETCH=1
export SYNFIG_ENABLE_WIDTH=1

Then run synfigstudio from the same terminal. You can probably find some way of getting these variables set automatically when you log in, but it depends on the distro. In Ubuntu you can put them in ~/.xprofile for example.

The polygon, draw, and sketch tools will be on by default in future releases of Synfig, from 0.61.07 onwards. They can be disabled by replacing 'ENABLE' with 'DISABLE' in the above lines.

Why doesn't walk.sif work?

It's a known bug. If you can look at the code and figure out what's broken, we'd love to have a fix.

The plant layer doesn't work/displays erratically/doesn't render. Why?

The plant layer should allow pictures like this one to be drawn, but again it had a bug that prevented if from working correctly in Synfig 0.61.06 and earlier. The bug was fixed in svn r620 and will be fixed in the next release.

Further fixes were layer added to stop it crashing when 'stem size' or 'splits' were set too high. They'll be in the next release (0.61.07).

Why does only the first frame of my animation render?

You probably have Use current frame checked in the render dialog box.

FAQs relating to earlier Synfig versions

These issues have been addressed in the current version of Synfig.

Missing icons? synfig/studio doesn't render anything?

You probably compiled synfig with g++ 4.1 using optimisation level 2 or higher. g++ has a bug that prevents synfig from compositing the images properly. Please recompile synfig using ./configure --enable-optimization=0 or disable optimisation and then rebuild the the synfigstudio images. The binary packages for some GNU/Linux distributions are affected by this. Bug #1509627

synfigstudio can't find icons?

(I know they rendered fine, but they show up with red crosses everywhere).

This is #1568925 that was introduced in SVN 180. Workaround is to set an environment variable at runtime like this: export SYNFIG_ROOT=/usr (or similar) or just install into /usr/local instead. Fixed in SVN r486.

I'm using synfigstudio on a laptop but can't draw anything using my mouse. What gives?

Try disabling the the touchpad from the input devices dialog. Unfortunately synfigstudio will not remember this setting so you have to do it every time you start synfigstudio.

Why is everything yellow? / Why are all the colors wrong?

This can happen when you switch between locales, due to a bug in version 0.61.05. It's fixed in the subversion repository (r228). To work around the problem, do the following: from the main window, choose File > Setup > Gamma and set all 3 sliders back to the default value of 2.2.


Languages Language: 

English • español • français