Releases/0.61.07

From Synfig Studio :: Documentation
< Releases
Revision as of 03:23, 8 September 2009 by Zelgadis (Talk | contribs) (Text replace - ']]' to '}}')

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
Languages Language: 

English

Warning!

This page contains outdated information.

The release of Synfig Studio 0.64.0 introduced new terminology and this translated page needs to be updated according to original English text.

You can help updating this page - see instructions here. Thank you!

warning end


Synfig 0.61.07

Tuesday, October 9, 2007 by dooglus

At long last, we have a new release! There have been lots of changes since the last release 4 months ago. This release fixes lots of bugs, and adds a few minor new features. Overall stability should be much improved, but you still need to apply a workaround to get decent stability on multi-core Windows machines.

The source code is available for ETL, synfig, and synfigstudio. Windows binaries are also available on the download page.

Read on for the list of changes since the last release.

ETL 0.04.10 - Bug fixes

  • Fix dirname for absolute paths (#1793306)
  • Fix minor issues and typos
  • Various changes to the 'angle' code. 89+360 < 90; 90 == 90+360, !360 is true, etc.
  • Resolve confusion about whether angles are clockwise, and whether they're stored in radians.
  • Fix 'make check' for 'fixed' so that it doesn't fail. Tidy the output, too.

synfig 0.61.07

  • Fix importing on amd64 (#1692825)
  • Fixes for the PasteCanvas layer (#1356449)
  • Clean up Layer menu and displayed layer names
  • Allow exported canvases to be used in more than one place within a canvas (#1785296)
  • Fix, extend, and enable the 'XOR Pattern' layer
  • Fix and extend the 'Plant' layer (#1790903)
  • Turn on plant layer (gunsmoke) in macwolfen.sifz example
  • Use 'fast gaussian' rather than 'gaussian' for blurs in pirates.sifz - it's faster!
  • Fix and enable the 'Timed Swap' valuenode conversion
  • Extend the 'Linear' valuenode conversion to work with colors and integers.
  • Enable basic motion blur display at all qualities
  • Fix an artifact on the curve gradient layer (#1792063
  • Add the 'Range', 'Repeat Gradient', 'Add', 'Exponent' valuenode conversions
  • Add the 'BLine Vector', and 'BLine Tangent' valuenode conversions (#1781903)
  • Fix problems with valuenode conversion (#1794374, #1795913, #1795922, #1796068, #1797488)
  • Allow gradients to be animated (#1568818, #1795802)
  • Stop TCB angle waypoints changing to type Linear on load (#1778930)
  • Use compression when saving to files with .sifz extension
  • Compressed example .sif files to .sifz to save space
  • Fixed Motion Blur layer (#1800783)
  • Allow building studio with gcc -O2 (#1509627)
  • Allow encapsulated layers to animate their z-depth, even when time-shifted (#1806852)
  • Fixed the Radial Blur layer when zooming in on the canvas (#1807709)
  • Fix several other bugs and crashes

synfigstudio 0.61.07

  • Fix some tooltips and menu stuff (#1787437)
  • Allow left-right scrolling in canvas window with shift + mouse-wheel
  • Rework mouse interaction with ducks and tangents
  • Move icons to a subdir
  • Fix some typos, several crashes (#1780016, #1785598) and other bugs
  • Re-enable sketch, draw, polygon by default
  • Add keyboard shortcuts for all tools
  • Fix crash when setting canvas resolution to zero (#1779616)
  • Add 'auto-export' checkbox and layer name box to the draw tool
  • Various GUI fixes (#1794006, #1796110)
  • File-selector fixes (#1383736)
  • Fix the View>Play menu entry to allow playback inside the workarea, shortcut Ctrl-P
  • Save to .sifz (compressed) format by default if no extension is given
  • Remember the path used when saving a document and default to it in future
  • Call new documents "Synfig Animation " by default, rather than "untitled0"
  • Don't quit until the user clearly answers "do you want to save?" (#1799722)
  • Remember the filename the animation was last rendered to, and default to it (#1799250)
  • Improved the 'Groups' function a little (#1368694). It's still quite broken
  • Fixed the colors displayed on the sliders in the Color Editor dialog
  • Added option to Bline Tool to allow positions to be automatically linked (#1776156)
  • Added menu entry to restore all dialogs to their default positions
  • Fix red "Animate Editing Mode" frame so it shows up in all themes (#1801220)
  • Allow user to "export SYNFIG_DISABLE_POPUP_WINDOWS=1" to make splash screen etc. less obtrusive
  • Fixed the logic used to decide which value to use when linking values together
  • Update child canvas time sliders when parent time slider is moved
  • Prevent the caret menu entries from being disabled when another canvas is closed
  • Show the correct initial quality level in the View > Preview Quality menu

synfig 0.61.07

Crashes:

Other:

  • Fixed importing images on amd64 (1692825)
  • Moved pixmaps to a subdir


Languages Language: 

English