Following a BLine (the very old way)

From Synfig Studio :: Documentation
Jump to: navigation, search
Languages Language: 

English


Contents

Introduction

 Important NOTE: You have synfig version 0.63.06 or newer (you probably do!) 
 then you should follow the new version of this tutorial. Since Synfig version 0.63.06 
  BLine has been renamed Spline and other terminology have changed.

This is only a rough draft. The content should be OK, but it needs tidying up and could really benefit from some screen shots. If you follow the tutorial, please consider taking some shots as you do so and uploading them here...

This bug report suggested a feature:

I would like to be able to draw a bline with N vertices and have a shape move along that bline (the whole shape or individual vertices). Currently the only way I have found to do what I want is to draw a bline, and then move a shape along that line manually at fairly small intervals (very frustrating). Example: A triangle that should move along a sine curve always pointing in the direction it is going to move next.

The feature has recently been added to Synfig (23rd September 2007) and will be in the next release.

Summary

We're going to:

Tutorial

This is a brief tutorial giving an example of how to use it:

Create the Animation

File > New

Time tab > End Time > 10s > OK

Create the Layers

select the BLine Tool

enable just the Outline checkbox

draw a bline that you want the arrow to move along

select the new bline layer, go to its parameters

right-click on the vertices parameter and "export" it it will ask for a name.

you can use whatever name you like but for this tutorial I'm calling it "path"

(note that you could have checked the 'auto export' box in the draw tool, and set the name in the text box at the top of the tool options to save having to chose export from the menu - it doesn't matter which you use)

switch back to the 'Normal' tool and look in the "Children" dialog.

expand the ValueBase Nodes and you'll see all the things that have been exported.

selecting them will allow us to re-use them elsewhere in the animation later

back in the bline tool, enable Fill and Outline checkboxes in tool options

draw an arrow or whatever, pointing to the right

select the outline, hit control-a to select all its ducks except the green position duck

drag the ducks so that the arrow is centred around the green position duck

add a rotate layer above the outline and region

encapsulate the rotate, outline, and region layers

rename the encapsulation layer "arrow"

so now you've got 2 top-level layers: a curved path, and an encapsulation containing an arrow and a rotate layer

Make the Arrow Move

select the "arrow" encapsulation layer

we want this layer to move along the "path" bline. the Origin parameter of an encapsulation layer can be used to move everything it contains right-click the Origin parameter and select Convert > BLine Vertex the Origin parameter will now be expandable - click the small triangle to its left to expand it

the Origin of the "arrow" layer is now defined by 3 sub parameters: a BLine, the amount to travel along the BLine, and a checkbox that we'll ignore for now. in the Children dialog, select the "path" ValueNode

then in the Params dialog, right-click on the "arrow" layer's BLine sub-parameter and "Connect" it to the selected "path" value

the arrow will move so that it is about half-way along the BLine path (because the Amount sub-parameter defaults to 0.5).

edit the Amount sub parameter to 0 and to 1, and see the arrow moves to one end of the path and then the other.

the "Loop" sub parameter determines what happens if you use a value outside the range 0-1 for the Amount. If "Loop" isn't checked, values less than 0 count as 0 and values greater than 1 count as 1. If "Loop" is checked, the value wraps around, so Amounts of 2.4, 1.4, 0.4, -0.6, -1.6, etc all act the same.

So we've got the arrow moving along the line, but only if we manually edit the Amount parameter. Let's get it to move automatically, by converting the constant Amount parameter into a linearly changing value.

Right-click the Amount parameter, and Convert it to Linear. This adds sub parameters Rate (how fast the value goes up, per second) and Offset (what value it has at time zero).

Set Rate to 0.1 and Offset to 0. That will make the value of Amount be 0 at time 0 and 1 at time 10s, so the arrow will move from one end of the line to the other throughout the course of the animation.

This linearly changing value of the Amount parameter will be useful later on, so let's export it into the Children dialog so we can find it easily later. Right-click the Amount parameter and Export it as "engine". I call it "engine" because this is the parameter that drives the animation.

Try File > Preview or View > Play to watch the animation. If you like, play with the sub-parameters - turn the Rate up to 0.25 and turn on the Loop checkbox and watch the preview again. You'll see that the arrow moves 3 times faster than before, reaching the end of the line after 4 seconds.

Turning Loop on means that it will then reappear at the start of the line, and keep moving. Not having Loop on would make it stay at the end of the line until the animation stopped.

Note that instead of using a Convert>Linear conversion to get the Amount sub-parameter to change over time, we could have used the more traditional method of turning on Animate Editing Mode and adjusting the parameter at different points in time. Either way, we can still export the Amount parameter so that we can use it again in the next step.

Make the Arrow Rotate

You'll notice that although the arrow moves along the line, it doesn't rotate to face the direction of travel. But that's what we're going to use the Rotate layer for.

Open up the "arrow" encapsulation layer and select the Rotate layer inside.

Right-click the Amount parameter, which specifies the amount to rotate, and Convert it to type BLine Tangent.

Open up the sub parameters, select the "path" value in the children dialog, and connect it to the rotate layer's BLine sub-parameter, and select the "engine" value in the children dialog and connect it to the rotate layer's Amount sub-parameter.

Now watch the preview and you'll see that the arrow is moving along the line, rotating to face the way it's traveling.

Results

This is the animation I ended up with: arrow-follows-line-tut.sifz

Commentary on the Feature

I've noticed that if Loop is on, and amount is 1.0, then it acts as if amount is 0.0, ie. the arrow jumps back to the beginning of the line in the last frame.

Also, the arrow takes the same time to move along each segment of the bline. So if there's a long straight part then a bendy complex part, the arrow will move much faster along the straight parts (since there will be less vertices in that part).

It would be good to have the option of having the arrow move at constant speed along the length of the curve.


Languages Language: 

English

Personal tools
Documentation